Solidworks

Fra Robin

Revisjon per 9. sep 2016 kl. 06:35 av Yngveha (Diskusjon | bidrag)
Gå til: navigasjon, søk

Innhold

Solidworks

The intention for this page is to contain information that will help you get started using solidworks.

Gaining access to Solidworks

The University of Oslo has got Solidwork licences for educational purposes. Solidworks can be downloaded from the Application Catalog run by USIT .

More about the Application catalog and the software database (Norwegian), (English)

Using Solidworks from Home

Solidworks can be used from home, but you need to be on UiO net, using VPN (Using the VPN client, not the one based on using webbrowser).

Solidworks can also be accessed through our server ifiserv-631.ifi.uio.no (intended for robotics students and robin staff only) Note that this also can only be accessed from the UiO net, meaning that you will need to either open VPN or use RDP to kontor.uio.no or any other windows login server, and then use remote desktop again to access ifiserv-631.


Getting started with Solidworks

  • Select a new "3D representation of a single design object" (solidworks->file->new->...).
  • Select the sketch-tab (A)

Image:solidworks01.jpg

  • Select a plane (B)
  • Use the sketching tools you need (C)
  • Select a suitable viewing angle (D)
  • Use the help-box to guide you (E) (Open it using Solidoworks->Help->Quick Tips)
  • When you have a closed loop in a plane, you can select "features" (A) and then extrude boss/base to make it thicker.
  • To create an output for 3D-printing, use save as...-> .stl

Making the first assembly

  • First, make and save the parts you want to assemble separately.
  • Use File->New->Template->Assembly
  • Find the first part in the "Begin Assembly" dialogue (B)
    • use insert components from the top menu (C).
  • Use the "Mate" feature (C) to align planes or axis.
    • Select view->Temporary axes to be able to select axes from cylindrical objects etc.
    • in the Mate selection box (B) you have options for how to move your parts together. Used correctly, they can turn your component in any desired direction.
      • In the bottom of the Standard Mates dialogue (B), you can select aligned or anti-aligned which may turn your object 180 degrees.
    • Plane surfaces that are coincident and aligned on top of each other (-usually achieved by using Mate twice-), will adhere to each other in print.
    • To Mate complex objects you can use the option View->Origins, and mate the origins. This will put origo for each part on the same spot.

Hints

  • Make sure your model is connected in every point, or you wont get a printable .STL file
  • Use the "for construction" feature unless you are 100% confident you will use the whole line you create. Having "solid" lines that isn't a part of the model will most probably yield a bad .STL
  • To fix a line length, you should anchor the points at each end, rather than anchoring the line itself.
    • Anchoring items with several properties (such as a line) doesn't fix all properties. Make sure you anchor correctly to avoid faulty designs.
  • You may set relations between lines by selecting them and select relation in the menu that appears on the left side.
  • Make sure you don't over-define your structures (Solidworks will warn you about this when it occurs).
  • Use Trim Entities to remove parts of lines that shall be removed (In case you weren't able to follow the advice above).
  • Solidworks use finite resolution, meaning that not every shape can be created mathematically correct. Attempting to force something "correct" may result in open loops, making extrusion impossible and STL output bad. Ensuring connection is more important than having a mathematically correct model.
  • Use tutorials when you want to try something new for the first time.
  • When saving assemblies as STL files, open the options-dialogue, uncheck Save all components of an assembly in a single file to ensure that objet studio will be able to change materials of separate parts.
    • In Objet Studio, there is an option for opening several files together as an assembly.
  • Have a look at our Printlog to see if there is something you can learn from other designs
  • To extract lines for construction from a plane of a 3D figure (especially curved lines which are hard to copy), select the plane, and choose convert entities in (C) when the sketch menu (A) is selected.
    • To deselect some, but not all lines after using convert entities, use Trim Enteties - also in (C) after selecting the sketch menu in (A)
Personlige verktøy