Design av PCB med Eagle PCB

Fra Robin

Gå til: navigasjon, søk

Innhold

Om Eagle PCB

Lages av CadSoft(www.cadsoft.de) www.cadsoftusa.com). Har en beskrivelse på WikiPedia:Eagle PCB. En noe begrenset gratis-versjon kan brukes til enkle design:

  • Area is limited to 100 x 80 mm (4 x 3.2 inches).
  • Only two signal layers can be used (Top and Bottom).
  • The schematic editor can only create one sheet.

Installasjon

  • Uten rettigheter som adminbruker:
    1. Last ned .zip-fil utgaven av programmet i ønsket språklig utgave (f.eks. engelsk)
    2. Pakk ut zip-fila, f.eks. på D:\EAGLE_versjonsnummer\ om du har D: på maskinen. Hvis ikke bør du ha tilgang til f.eks. C:\TEMP\ .. eventuelt kan du bruke hjemmeområdet.

Tegning av skjematikk

Se gjerne eagles egen tutorial/tour.

Steg for steg:

  1. Lag et nytt prosjekt: "File→New Project..." og navngi det
  2. Høyreklikk prosjektet, velg "New→Schematic" og et skjematikkvindu dukker opp.
  3. Velg "Add..."-symbolet på venstre side for å legge til en komponent.
  4. Skriv inn en del av komponentnavnet i søkefeltet.
    • Tips: Bruk wildcards "*" og "?" for å søke.
  5. Når du har lagt ned komponentene trekker du wires mellom dem.
  6. Lagre når du er ferdig

Det finnes endel fler muligheter i skjematikken, flere libraries og manualer kan lastes ned fra eagles nettsider. Det fnines også mer dokumentasjon om hvordan å lage egne komponentbiblioteker osv.

Design av PCB

  • Fra skjematikken kan man ganske enkelt klikke "File→Switch to Board" og man får opp et brett hvor footprintene ligger klare utenfor et område på 100x80mm.
    • uten skjematikk: velg "New-Project" og "New Board".
  • Sett foretrukken gridstørrelse samt cm/inch ved menyen "View-Grid".
  • I feltet oppe til venstre står x,y coordinatene til cursor, disse er fine å orientere seg etter når man lager hull til feste av PCB.
  • Lurer du på størrelsen på en komponent eller hvor den er på PCB'en trykker du "View-Info" og komponenten.
  • Gule streker marker den korteste vei i luftlinje mellom to noder i kretsen som må kobles sammen. Når man har tegnet litt kan man oppdatere disse ved hjelp av funksjonen Ratsnest.
  • Flytt komponenter inn på det lovlige området og roter de med høyre museknapp mens du flytter.
  • Velg 'Route' for å trekke baner og høyreklikk for å tillate andre typer former på banen du ruter, e.g. rettvinklet/45 grader osv.
  • Bruk 'Ripup' når du skal ta baner bort igjen
  • Lag som er relevante for produksjon ved fresing:
    • "(1) Top" - Topplag for kobberbaner. Pass på at lag "Top" er valgt før du tegner. Sett "Width" (banebredde) i menyen opp i midten før du tegner.
      • Typisk kommando for å tegne baner: "Draw-wire".
      • Typisk kommando for å tegne kobberring rundt viahull: "Draw-circle"
    • "(16) Bottom" - Bunnlag for kobberbaner (baksiden av PCB'en). Pass på at lag "Bottom" er valgt før du tegner. *** Sett "Width" (banebredde) i menyen opp i midten før du tegner.
      • Typisk kommando for å tegne baner: "Draw-wire"
      • Typisk kommando for å tegne kobberring rundt viahull: "Draw-circle"
    • "(45) Holes" - Hull for via/komponenter/feste. Du stiller først inn diameter i "Drill"-menyen oppe til venstre.
      • Typisk kommando for å tegne hull: "Draw-hole"
  • Typisk problem med gratisversjonen: Man får ikke lagt til ny komponent. Grunn: "Boardet" har forskjøvet seg og man forsøker å plassere komponenten utenfor det lovlige gratisområdet. Løsning: Zoom og pan.
  • Når du er ferdig med å rute kan du teste ERC og DRC.

Eksport av Gerber274x og NCDrill

  1. Tegn opp PCB'en. PCB'en kan være på 1-2 lag, pluss evt. VIA'er som du lager som enkle hull med passende mengder av kobbermateriale rundt i topp/bunn-lagene. Du trenger altså bare å beskrive/tegne topplaget pluss evt bunnlag pluss evt. hull. Eagle bruker følgende navn på lagene:
    • "(1) Top" - Topplag for kobberbaner.
    • "(16) Bottom" - Bunnlag for kobberbaner (baksiden av PCB'en).
    • "(45) Holes" - Hull for via/komponenter/feste.
    • Tilgjengelig bordiametre for hull i fresemaskinen:
    • Alle andre lag er ikke interessante med hensyn på produksjon ved fresing. Eagle designtips
  2. Generer design-filer for topp/(bunnlag) pluss evt. (hull)
    • CAM jobs: Generelt - dobbelklikk aktuell CAM jobb og klikk "FILE-OPEN-BOARD" for å importere boardet inn i jobben.
    • "Layout2.cam" job - gir filer for papir-printer / visuell verifikasjon
      • x.eps - vanlig postscript.
    • "Gerber274x.cam" job - gir Gerber filer.
      • x.cmp - Gerberfil som beskriver kobber-baner for topp laget.
      • x.sol - Gerberfil som beskriver kobber-baner for bunn laget (baksiden av PCB'en).
    • "Excellion.cam" job - beskriver hull i PCB'en (for VIA).
      • x.drd - NCdrill fil.

Import til Circuitcam og boardmaster

Fil:LPKF Product Catalog english.pdf

  • CircuitCam:
    • Importer x.cmp, (x.sol) og (x.drd) -filen(e).
    • Assign x.cmp til "Top layer". (Assign x.sol til "Bottom layer"). (Assign x.drd til "Drill Plated"). Merk at evt. bunnlag er speilvendt i CircuitCam.
    • Generer kontur (PCB ytterkanter som freses av) ved å
      • Selekter lag: "BoardOutline", tegn opp en "Closed path" rundt PCB'ens ytterkanter
      • Velg "Contour ruting" med "source" = "current layer"/"BoardOutline" samt "used tool"= LPKF cutting tool / 2.0mm, "Break Out" = "automatic"
    • Pass på at det ble tilstrekkelig med "break out tabs" slik at PCB'en ikke løsner og ødelegges mens den freses av
    • Evt. Generer "rubout areas" (områder fritt for kobber)
    • Evt. Legg ut tekst (eget navn e.l.) i top eller bunnlaget
    • Trykk "Insulate all layers". Her kan du også inspisere hvilke fresehoder og spor som vil bli brukt.
    • Eksporter designet som en x.LMD fil (export - LPKF CircuitBoardPlotter)
  • BoardMaster:
    • Start opp progammet ved å klikke på Cancel i boksen "Switch the machine on !"
    • Importer filen x.LMD. Velg "Milling Top" / "Milling Bottom" (hvis 2-lags), zoom inn, og sjekk at fresesporene er synlige
  • Produksjon
    • Ta kontakt med en av labingeniør og avtal bruk av maskinen. Maskinen må kjøres av Yngve eller Håvard (maskinen kan ødelegges ved feilaktig bruk, koster >250.000Kr), med filen x.LMD som du selv har generert.
    • x.LMD må være ferdig verifisert på forhånd.


  • FAQ
    • Får ikke lagret x.LMD fra CircuitCam. Feilmeldig: "Stretch limit exceeded"
      • Prøv å ikke ha BoardMaster oppe samtidig. Det er en viss interaksjon i mellom programmene.
    • Kan man lage vilkårlig store/små kort?
      • Ja, max størrelse er ca. 229mm x 305mm
    • Hvor store må viahullene være?
      • Borr 0.2mm større hull enn diameteren på naglene.


Linker

Generelle PCB design tips: alternatezone

Personlige verktøy